August 23, 2010

Internet only works in safe mode (Windows7 x64)?

Ive been haing this issue since yesterday. I can connect to my wireless router with no problems, but the internet dos not work on IE7 or FireFox. In safe mode, I can connect to the same router wirelessly, and can use the internet. In normal mode, I have full bars, I can ping and use aim. But if using the internet, yahoo messenger or Windows live, it says I am not connected. My trendmicro is up to date, and no viruses found. I cant do a system restore, bc the entry I have in there is corrupted. I tried using the Windows 7 repair utility on startup, and scanned the startup files, which were corrupted, but even after cleaning them up I am still having issues. any help?

Below is a hijack this report: also, I am a techie, so please you can speak your mind.

In Safe mode:

Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 12:16:21 PM, on 2/6/2010
Platform: Unknown Windows (WinNT 6.01.3504)
MSIE: Internet Explorer v8.00 (8.00.7600.16385)
Boot mode: Safe mode with network support

Running processes:
C:WindowsSysWOW64NOTEPAD.EXE
C:Program Files (x86)Internet Exploreriexplore.exe
C:Program Files (x86)Internet Exploreriexplore.exe
C:Program Files (x86)Trend MicroHijackThisHijackThis.exe

R1 - HKCUSoftwareMicrosoftInternet ExplorerMain,Search Page = http://go.microsoft.com/fwlink/?LinkId=5…
R1 - HKLMSoftwareMicrosoftInternet ExplorerMain,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=6…
R1 - HKLMSoftwareMicrosoftInternet ExplorerMain,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=5…
R1 - HKLMSoftwareMicrosoftInternet ExplorerMain,Search Page = http://go.microsoft.com/fwlink/?LinkId=5…
R0 - HKLMSoftwareMicrosoftInternet ExplorerMain,start Page = http://go.microsoft.com/fwlink/?LinkId=6…
R0 - HKLMSoftwareMicrosoftInternet ExplorerSearch,SearchAssistant =
R0 - HKLMSoftwareMicrosoftInternet ExplorerSearch,CustomizeSearch =
R1 - HKCUSoftwareMicrosoftWindowsCurrentV… Settings,ProxyOverride = *.local
R0 - HKCUSoftwareMicrosoftInternet ExplorerToolbar,LinksFolderName =
F2 - REG:system.ini: UserInit=userinit.exe
O1 - Hosts: ::1 localhost
O2 - BHO: (no name) - 02478D38-C3F9-4efb-9B51-7695ECA05670 - (no file)
O2 - BHO: AcroIEHelperStub - 18DF081C-E8AD-4283-A596-FA578C2EBDC3 - C:Program Files (x86)Common FilesAdobeAcrobatActiveXAcroIEHelper…
O2 - BHO: Skype add-on (mastermind) - 22BF413B-C6D2-4d91-82A9-A0F997BA588C - C:Program Files (x86)SkypeToolbarsInternet ExplorerSkypeIEPlugin.dll
O2 - BHO: RealPlayer Download and Record Plugin for Internet Explorer - 3049C3E9-B461-4BC5-8870-4C09146192CA - C:Program Files (x86)RealRealPlayerrpbrowserrecordplu…
O2 - BHO: Windows Live Sign-in Helper - 9030D464-4C02-4ABF-8ECC-5164760863C6 - C:Program Files (x86)Common FilesMicrosoft SharedWindows LiveWindowsLiveLogin.dll
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - DBC80044-A445-435b-BC74-9C25C1C588A9 - C:Program Files (x86)Javajre6binjp2ssv.dll
O4 - HKLM..Run: [HControlUser] C:Program Files (x86)ASUSATK HotkeyHControlUser.exe
O4 - HKLM..Run: [ATKOSD2] C:Program Files (x86)ASUSATKOSD2ATKOSD2.exe
O4 - HKLM..Run: [ATKMEDIA] C:Program Files (x86)ASUSATK MediaDMedia.exe
O4 - HKLM..Run: [ADSMTray] C:Program FilesASUSASUS Data Security ManagerADSMTray.exe
O4 - HKCU..Run: [swg] "C:Program Files (x86)GoogleGoogleToolbarNotifierGoogl…
O4 - HKCU..Run: [Skype] "C:Program Files (x86)SkypePhoneSkype.exe" /nosplash /minimized
O4 - HKCU..Run: [msnmsgr] "C:Program Files (x86)Windows LiveMessengermsnmsgr.exe" /background
O4 - HKCU..Run: [Messenger (Yahoo!)] "C:Program Files (x86)Yahoo!MessengerYahooMessenger.ex… -quiet
O4 - HKCU..Run: [LightScribe Control Panel] C:Program Files (x86)Common FilesLightScribeLightScribeControlPane… -hidden
O4 - HKCU..Run: [ehTray.exe] C:WindowsehomeehTray.exe
O4 - HKCU..Run: [Aim6] "C:Program Files (x86)AIM6aim6.exe" /d locale=en-US ee://aol/imApp
O4 - HKUSS-1-5-19..RunOnce: [mctadmin] C:WindowsSystem32mctadmin.exe (User 'LOCAL SERVICE')
O4 - HKUSS-1-5-20..RunOnce: [mctadmin] C:WindowsSystem32mctadmin.exe (User 'NETWORK SERVICE')
O4 - Startup: MagicDisc.lnk = C:Program Files (x86)MagicDiscMagicDisc.exe
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:PROGRA~2MICROS~3Office12EXCE…
O9 - Extra button: Blog This - 219C3416-8CB2-491a-A3C7-D9FCDDC9D600 - C:Program Files (x86)Windows LiveWriterWriterBrowserExtension.dll
O9 - Extra 'Tools' menuitem: &Blog This in Windows Live Writer - 219C3416-8CB2-491a-A3C7-D9FCDDC9D600 - C:Program Files (x86)Windows LiveWriterWriterBrowserExtension.dll
O9 - Extra button: Send to OneNote - 2670000A-7350-4f3c-8081-5663EE0C6C49 - C:PROGRA~2MICROS~3Office12ONBttnIE.d…
O9 - Extra 'Tools' menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C4

So what were you doing when it stopped working?

If you recently uninstalled Norton, you need to run the official Norton uninstall utility, otherwise you have a high chance of having network problems exactly as you have described.

Internet only works in safe mode (Windows7 x64)?